Jump to content
  • Create an account or sign in to use the shoutbox

    You need to be a member in order to be able to chat with other users.

Sign in to follow this  
twostars

Patch issues with 2.117

Recommended Posts

TL;DR: If your client is bugged, reinstall (even if you tried reinstalling before, just do it).

Hey guys,

Patches 2.117~2.119 introduced a lot of new, major, (potentially) breaking changes.

After releasing, we encountered:

  • Magic bag slots not behaving correctly. Anyone who tried to move a bugged item in their magic bag probably has that item in their tattoo slot now, but since it only happened to a few people who encountered this when we initially set the server up, and the item can be moved back out without affecting anything, we didn't bother to revert these.
  • Genie no longer being free (or more specifically, it wasn't giving you the points to use it).
  • Return of some targeting issues which affected skills like minor healing. This wasn't actually caused by this patch specifically, but a setting USKO added a while back (2.08x) which they've tinkered with a few times since.
  • Client freezing when using in-zone warps (e.g. Boatman).

These were all fixed.

Additionally, as is always the case with patches, players tend to have issues updating for various reasons -- usually Windows permissions (i.e. when not running as Administrator), or important patch files being deleted or blocked by antiviruses (including Windows Defender, because ApexKO's folder needs to be added to its exclusion list).

Having said that, this patch caused update issues for an entirely different reason: we hit 32+ patches. The problem with this, is mgame's launcher is designed to only download 31 at a time.

For players installing/reinstalling, as of patch 2.117, you would have more than 31 to download.

By itself, this is fine; it downloads the first 31, the launcher closes, and it should continue -- only it doesn't, because it's saving the latest version (2.120) in server.ini, instead of the last installed version (2.116).

So it downloads 2.116, it closes and says the client is now at version 2.120. It's not, because it's still missing 2.117~2.120. Trying to start it obviously breaks for various reasons (invalid TBLs, outdated client version, etc), since it isn't actually up-to-date. Ouch.

To fix this, we've done a few things.

We've merged all of the prior patches (patch 2.084~2.120) into one ~87MB patch. This doesn't include anything that could be flagged by an antivirus, so you won't ever need to redownload it. The files that could trip your antivirus (please add ApexKO's folder to your antivirus' exclusion list!) are in patch 2.121, which is much smaller, in case you do need to redownload them. ^_^

Anyone using the 2.083 installer or any client version prior to 2.120 will be brought up to date.

If your client is bugged, you will need to reinstall -- even if you've reinstalled previously. All of the patches are in one, so you won't experience the same issue and your client will be fixed.

We've also updated the client installer to 2.121 for new players. Download links are available on our website at https://www.apexko.com/download for Google Drive, MEGA, and MediaFire.

Finally, we fixed the launcher's versioning behaviour in 2.121+. So in the future, if we ever do exceed 31 patches again, nothing will break horribly like it did this time.

... and there we were, worried about the major changes in the new 2.167 client breaking things. Pfft. Nope, the bigger problem was having too many patches. Okay. :(

As always, thanks very much for your patience and understanding as we worked to resolve these issues. ^_^

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×