Jump to content
  • Create an account or sign in to use the shoutbox

    You need to be a member in order to be able to chat with other users.

Sign in to follow this  
adadad01

Can't launch the game - Application Error

Recommended Posts

Greetings,

I'm getting the error shown in the picture below while starting the game. 

ZWwAOAQ.png

I also did some research about this error in forum but answers related to this problem couldn't fix my problem. Most of the answers are relating this issue to an antivirus program but the problem is, I don't even use any antivirus program.

Some details about my system and what i have done:

  • I don't have any antivirus program.
  • I've DirectX installed on my system.
  • I am using Windows 10 Version 1607, build 14393
  • Windows Firewall is completely disabled as well as Windows Defender.
  • Added exception to DEP for both Launcher and KnightOnline.exe, didn't help.
  • I also have downloaded game client from multiple sources(GDrive and Mediafire) and reinstalled on different locations 4th times.


So what may cause this issue? Any help is appreciated.
Thank you.

 

Share this post


Link to post
Share on other sites
1 hour ago, muffzord said:

I had the same problem and similar situation. Updating graphics drivers helped in my case.

Unfortunately, It didn't work for me.

 

32 minutes ago, Holland said:

Realy easy, or reinstall because could be windows defender or some other crap deleted something. (MAKE SURE ALL DISABLED)

Or open as administrator. 

Have you read what i wrote? I've disabled Windows Defender/Firewall completely. Other than that starting KO with root permissions also didn't solve the problem.

Share this post


Link to post
Share on other sites
13 hours ago, adadad01 said:

Unfortunately, It didn't work for me.

 

Have you read what i wrote? I've disabled Windows Defender/Firewall completely. Other than that starting KO with root permissions also didn't solve the problem.

Have you read what i said?
Indeed, then as i told you it could be that you disabled to late or something or restarted computer then everything gets turn back on.

If you want i can help via teamviewer.

Sent me details via pm

Share this post


Link to post
Share on other sites
9 minutes ago, Holland said:

Have you read what i said?
Indeed, then as i told you it could be that you disabled to late or something or restarted computer then everything gets turn back on.

If you want i can help via teamviewer.

Sent me details via pm

I've sent details to you by pm.

Share this post


Link to post
Share on other sites

d3d9.dll probably doesn't exist in your client folder. This tends to happen when it's deleted or blocked by an antivirus/Windows Defender, otherwise I don't know why it wouldn't be there.

So, check that it exists there first. If it doesn't exist there, you'll want to reinstall. If it still doesn't exist, something on your end is removing it.

If it IS there, it may be that it's not launching from that client folder (the launcher can sometimes do weird things and attempt to launch from another Knight Online client you have installed).

This isn't really a solution for this, but a temporary workaround to test this but you can try this but you can:

  • right-click KnightOnline.exe in your client folder,
  • click "Create shortcut",
  • right-click on the shortcut it created
  • click "Properties"
  • in "Target:" add "E03ED890-8E94-4B42-B1C5-3CDA401AA9C2" to the end (with a space between it and .exe), so it should look something like (the quotes are intended):
  • "C:\Program Files (x86)\ApexKO\KnightOnline.exe" E03ED890-8E94-4B42-B1C5-3CDA401AA9C2
  • hit "Apply", "OK" and then try starting it from the shortcut.

If this works, the launcher is probably indeed getting confused and trying to start from another client folder. Offhand I'm not sure what to do about this, but the above should let you get ingame for now (you just won't be forced to go through the launcher... so you'll have to remember to update).

If that still produces the same error, then I may need to take a closer look on your PC. If you can PM me Teamviewer details so I can check it out personally that would be appreciated. :)

Share this post


Link to post
Share on other sites
33 minutes ago, root said:

If that still produces the same error, then I may need to take a closer look on your PC. If you can PM me Teamviewer details so I can check it out personally that would be appreciated. :)

Unfortunately, i am still facing with this error message even after creating launcher shortcut with the parameter that you gave to me. I've sent my TeamViewer details, please check your inbox. Thank you.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×